ERROR: `phpize’ failed and make: *** [oauth.lo] Error 1

Posted by on April 25, 2012 in PHP, Ubuntu | 2 comments

I recently tried to install oauth on Ubuntu and got two errors during the process. Unlike what is said, it was not the simple install from pecl.

sudo pecl install oauth

This should work, but it threw my first error

ERROR: `phpize’ failed

More searching revealed that the phpize script is found in the php5-dev package, and those who had the error installed that to make it work.

sudo apt-get install php5-dev

It got farther this time, but still had issues. I got the next error when running the pecl oauth install again.

make: *** [oauth.lo] Error 1

More research found that another dependency was missing. To install that

sudo apt-get install libpcre3-dev

After both of the packages were installed oauth downloaded and installed without issue.

If you enjoyed this post, please consider leaving a comment or subscribing to the RSS feed to have future articles delivered to your feed reader.

2 Comments

  1. Brilliant, had been looking for this in a few other places, this did the trick.

    • Thanks for stopping by!

Leave a Comment

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>